Oil press probs.

Discussion in 'Chevy C/K Truck Forum' started by 4x4squared, Jun 5, 2012.

  1. 4x4squared

    4x4squared Rockstar 3 Years 100 Posts

    My brother has a 90s suburban (don't know exact year) with a 350 tbi that keeps losing oil pressure and occasionally stalls when it gets hot. When the truck cools back down, all is well and pressure builds perfectly and truck runs like a dream. Any ideas, suggestions, etc? Thanks in advance.
     
  2. K15 Blazer Guy

    K15 Blazer Guy Member 2 Years 100 Posts

    that sounds really serious... are you sure the lack of oil pressure is whats causing it to stall though?

    what does the watter temp say when its stalling out? cause i hear "hot" and "stalling" i think siezing up, and that IS catastrophically bad...

    my truck also looses oil pressure as it drives. by the time i hit the interstate and start cruising with a warmed engine, the pressure is about 7psi on the dash..... which cant be right. im pretty sure the engine would have takken a huge S*@^T by now...
    so it must be the oil pressure sending unit (i think it is next to the distributor on the block deck...)
    so troubble shoot that first. cause the sensors talk to the computer, and may be forcing it to turn of... so start there. i will be changing mine out soon as well.
    but see if that may be it

    does anyone know if there is only that one oil psi sensor on the 350 V8?
    because i know water temp has 2, one for the guage, and one for the ECU.
     
  3. 4x4squared

    4x4squared Rockstar 3 Years 100 Posts

    Well the oil sending unit was my first thought and i had him pick one of them up the other day (it is back by the distributor). I have no idea if the stalling and oil press is connected or not. to be completely honest, the only reason i posted something on here was because of the stalling and i wanted to see if anyone had heard of both probs at the same time. i guess when he gets on the freeway and the truck starts to get hot, thats when the oil press drops to nothing. hes gettin that replaced this weekend and i guess well go from there.
     
  4. K15 Blazer Guy

    K15 Blazer Guy Member 2 Years 100 Posts

    ok, yeah, you have my same oil problem then.
    removing the oil cooler and going back to the PH filter improved it a little, but oil level is a contributing factor as well.

    i dont think your oil PSI is related to stalling. i have never heard that senario play out before. the only time my truck has ever stalled is when i let the fuel get very low, and i brake hard to a stop comming down big hills.... then it restarts fine in time to make the next green, easily.

    check fuel pressure, throddle bodies, and fuel filter. they actually need to be changed every 6k miles or so (very frequently) due to the fact that gas these days is ****ty watered down "ethonyl?" low octaine clean emmission minded......
    anyway, that little paper filter gets hundreds or thousands of gallons through it, so change it often.

    troubble shoot the fuel, ignition, and sensor connections and let us know
    GOODLUCK
     
  5. 4x4squared

    4x4squared Rockstar 3 Years 100 Posts

    Update: My brother has yet again decided its not important having no oil press and stalling is ok. guess hes just gonna let it go for now...
     

Share This Page

Newest Gallery Photos