1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Oil pressure high

Discussion in 'GM Powertrain' started by black07sierra, Jun 7, 2012.

Random Gallery Photos

  1. black07sierra

    black07sierra New Member

    07 NBS Sierra 5.3. Ck engine light came on. Says oil pressure level high. Unsafe level. Anyone else ever run into this??
  2. dpeter

    dpeter New Member 100 Posts

    Never knew they had an upper limit. Was this pressure to high or oil level to high?
  3. black07sierra

    black07sierra New Member

    Pressure. Oil pressure gauge pegging out at 80 psi every now and then.
  4. dpeter

    dpeter New Member 100 Posts

    I do not know what would have to fail to get high oil pressure intermitantly but a failing pressure sending unit could give a false reading. I would check the actual oil pressure to see what it was or take a chance and just change out the sending unit. Better yet, wait till someone with some first hand knowledge posts an opinion.
  5. black07sierra

    black07sierra New Member

    I was thinking oil pressure switch too. It's only a $40 part. Hopefully someone that has access to the tsb's can look to see if this was brought up. In case anyone asks my engine has already had the deflector plate installed.
  6. Crawdaddy

    Crawdaddy Moderator Staff Member Platinum Contributor 1000 Posts 100 Posts

    High oil pressure could also point to crud built up in an oil passage causing a restriction which would jump up the pressure. If there is a restriction, something isn't getting oil which could mean premature failure of that part.
  7. black07sierra

    black07sierra New Member

    Engine was pulled and new pistons and rings were installed 12000 miles ago. Still burns oil but GM said its within specs. Thats another story. Oil changed regularly. I'm gonna change oil pressure switch this weekend.
  8. dpeter

    dpeter New Member 100 Posts

    Did GM do the repair and do you have a warranty? If so then that is where I would start.
  9. black07sierra

    black07sierra New Member

    GM did repair and it's out of warranty now. Gonna replace the sensor tomorrow. The gauge dropped to 0 psi for about 20 miles yesterday and then back to 80.
  10. rileyjr16

    rileyjr16 New Member 1000 Posts 100 Posts

    Sounds to me like its the sensor. Same thing is wrong on my uncle's 05. His pegs out high and claims to have 0% oil life.

Share This Page