1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

On the verge of insanity with this

Discussion in 'Chevy Truck Talk & GM News' started by rileyjr16, Apr 17, 2012.

  1. rileyjr16

    rileyjr16 Active Member 1000 Posts

    Ok now I am really stumped :grrrrrr:. I was sitting in my truck talking to my cousin with it off but the key was in and the radio was playing when I realized my interior courtesy lights came on. This strikes me as odd because the fuse is pulled for the interior courtesy lamps. When I pulled the fuse, "cargo lamp on" popped up in the message center. Here is what I did;

    After getting home, I pulled the light bulb out of the dome socket so that i can put the fuse back in and have light from the map lights when I need it and not drain the battery, with the fuse still out, I touched the bulb to the dome socket and the lights went out and when I broke contact, the lights came back on.

    With the fuse out, there are 2 ways to shut the lights off with the bulb out of the dome socket, the illumination switch by turning it up till it clicks or by pushing the cargo lamp button, but the "cargo lamp on" still is in the message center. Also when I open the door, they go off as well as the radio and the chime works.

    I put the fuse back in which makes "cargo lamp on" go off in the message center but leaves the lights on with no possible way to shut them off; the dome bulb is pulled out, and once it makes contact with the socket, the lights this time stay on.

    When I start the truck, the lights will come on, and the only way to shut them off is the illumination switch or the cargo lamp switch; and when I shut it off and remove the key, they go off. However when I push the key in, they will kick on after about 30 or so seconds and this is with the fuse out.

    I'm sure I'm pulling power from another source but I'm not sure where to start looking other than loose wires but I can't seem to find any.

    I may try to replace the switch in the door and see if that does anything. I am on the verge of insanity with this. Any sort of help is greatly appreciated. My last resort is a "shop" but that might be a while and $$$.
  2. osgprometheus

    osgprometheus New Member

    You can test the current with a power probe to see if you have a short in the circuit to the cargo light. That would be where I start. Next the dome light circuit. If nothing is found it may be in your BCM. But I'd test it in those spots first.
  3. rileyjr16

    rileyjr16 Active Member 1000 Posts

    voltmeter works? The lights don't seem to be as bright as they should be.
  4. donyms

    donyms Active Member 1000 Posts

    Check your cargo light sockets for any sign of corrosion, discoloration, rust or anything other than shiny contacts, they get water in them because the seal around the 3rd brake light can leak over time or if someone changes a bulb. That would be where I would check first. Good luck. :glasses:

Share This Page