1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Oxygen sensor DTC P0036 will not go away.

Discussion in 'General Chevy & GM Tech Questions' started by deepstuff, Apr 24, 2012.

  1. deepstuff

    deepstuff Rockstar

    Had DTC P0036, Replaced drivers side post Cat sensor and reset DTC. P0036 keeps coming back.



    ’07 new body style 6.0L Vmax
     
  2. dipstick

    dipstick Member 2 Years 100 Posts

    02 is working doing it,s job just the heater built into the 02 sensor is not.
    It is a emissions part of it . Warms 02 up faster so it can start reading faster.
    Here is a link of what maybe wrong. I,am having this problem also . I have a good ground but not getting the voltage to run heater .
    Probably a bad wire in the harness somewhere. Or maybe need to get a oem 02 i installed a bosh but some ay no get a oem will not have this trouble . We will see .
    Here is a link with things to check. www.engine-codes.com/p0036.html
     
  3. deepstuff

    deepstuff Rockstar

    I fitted a DENSO after getting the P0036 with original fitted.
     
  4. dipstick

    dipstick Member 2 Years 100 Posts

    Need to check link out things to check..will be one of these. Unless you know how to check things with a meter and have the specs
    Will have to take to a garage. Wish i could help ore but do not know specs to all.
     
  5. deepstuff

    deepstuff Rockstar

    Now I`m getting P0036, P0054 and P0141

    At idle HO2S12 = 440-600mv
    HO2S22 = 195 -180mv
     
  6. GMC Tank

    GMC Tank New Member

    I'm having the same problem. I have changed my O2 sensor twice and I think its in the harness. I'm searching trying to find out about a wiring harness.
     
  7. Beep

    Beep New Member

    I have P0036 and stabiltrac warning on a "07 Avalanche , changed rear o2 sensor and getting power to connecter (14.63 volts w/engine running ) . Can someone give info on how to test ground and what color wire .
     

Share This Page