1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

parking light issues only w/headlights on

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by slammed95burban, Jul 22, 2012.

Newest Gallery Photos

  1. slammed95burban

    slammed95burban New Member

    hey whats up guys. i have a 1995 suburban and i just towed a questionable trailer,and now when i turn the headlights on all the running lights turn off along with the dash lights. all the other functions still work brake lights, blinkers, and hazzards just no running lights. if i turn on just the parking lights everything works fine. the only thing i can see visually wrong is the trailer light connecter is slightly melted, but none of the fuses are blown. any help is apreciated thanks.
     
  2. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    Sounds like every thing was fine until the trailer was plugged in.

    I'd disconnect the "slightly melted" trailer connector and see what the lights do.
     
  3. slammed95burban

    slammed95burban New Member

    alright so i put a little work in on the burban today after work, and turns out its the headlight switch. $41.12 at oreilly. never thought the switch would cause such a weird problem. thanks for the help though
     

Share This Page