1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Passenger side mirror turn signal led out

Discussion in 'Lighting Discussion' started by MXG286, Jul 14, 2011.

  1. MXG286

    MXG286 New Member

    New to the forum here. I have a 2003 Silverado with the turn signals in the side mirrors. My passenger side is not working but I have turn signals working on that side. Is there something simple i should look for?
  2. sstoner911

    sstoner911 New Member 1000 Posts 100 Posts

    Have you checked the bulb?
  3. Ridyn

    Ridyn New Member 100 Posts

    I think the LED's run on a circuit board like most LED's do. I am not too sure if it's singles or if they are all on one big board, if they are on one board then you're gonna have to replace the internals, and if they do not only replace the internals they might just have to replace the entire mirror. Unfortunately I do not know how our mirrors work for the LED's, but if they are like any common LED system that works with multiple LED's it's gonna be on a LED circuit board.
  4. MXG286

    MXG286 New Member

    Well I finally got around to checking the leds and I tried to run the drivers side mirror with a jumper from the passenger side and nothing. I also bought some aftermarket leds and they did not work. Is there a common point where shorts are known to happen. My next course of action is to see if I can get a reading on my multimeter for the power to the turn signal prior to the door control unit. If I get power I know where I am loosing it. If not where would be the next area to check? i.e. the next harness connection. Keep in mind that I have turn signals working but just not the one in the passenger mirror.
  5. dedmon27

    dedmon27 New Member 100 Posts

    Not sure but since l.e.d., you might not see 12 volts thru the pig tail. My 03 has the same mirrors. I broke my drivers side, and replaced it with one I found on Ebay. The cheapest way I found to replace it. Did a write up with pics. Hope this helps.
  6. MXG286

    MXG286 New Member

    The pigtail should see 12 volts. Mine was not. I ended up finding out it was the blue wire in the harness that was not showing any continuity between both ends. It must have gotten pinched somehow and broken. I ran a wire from the truck fuse block to the light and we are good to go.

Share This Page