1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

"pinging" noise

Discussion in 'Lifted & Offroad Suspension' started by jarratt11, Dec 6, 2009.

  1. jarratt11

    jarratt11 New Member

    hello everyone. have a 03 silverado z71 ext. cab. during fast acceleration or while shifting from 1st -> 2nd and 2nd -> 3rd, there in a loud "pinging" noise in the rear it sounds. There is no play in either driveshaft and no vibration while cruising. Does anyone know if this could be the u-joints or the ring and pinion? Any other ideas?? please help!
     
  2. Chaser1

    Chaser1 Rockstar

    Hi, I got the same problem on my 00 silverado single cab and can't figure it out, I have taking it to two diff shops and the first shop said that I needed new shocks and the other place just gave up..,,
     
  3. jarratt11

    jarratt11 New Member

    i replaced the u-joints, but it is still pinging. looks like ill just be lettin it ride like it is. it runs fine no vibration or hard shifting, so im not sure.
     
  4. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Try pumping the slip joint full of grease.
    The drive shaft is a large hollow tube that amplifies any noise, sometimes when the slipjoint isnt packed with grease like it should be it'll give pinging sound.
     

Share This Page