GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

pinging

Discussion in 'General Chevy & GM Tech Questions' started by imrdcobra, Mar 28, 2010.

  1. imrdcobra

    imrdcobra New Member

    Joined:
    Jan 5, 2010
    Messages:
    2
    Likes Received:
    0
    I have a 1997 suburban 5.7 it has 160,000 miles on it and it started pinging about a year ago i put prem gas in it it seemed to cure it then recently it started pinging even with prem gas i did the water down the intake trick to clear the carbon and it still pings.Does anybody have any ideas?
    #1
  2. murdog94

    murdog94 New Member

    Joined:
    Feb 20, 2008
    Messages:
    8,198
    Likes Received:
    18
    Check your timing.. Also make sure that your disributor doesnt have bad bushings by simply pulling the cap and seeing how much play is in the shaft....
    The Vortecs distributors are pretty common for going bad. Ive had to do 3 in the last 6 months on 3 of my buddies trucks and all of them were between 140K, and 200K...
    #2
  3. imrdcobra

    imrdcobra New Member

    Joined:
    Jan 5, 2010
    Messages:
    2
    Likes Received:
    0
    Just did complete tune up including coil wires etc.No check eng light not on. And the timing is set there is no adjustment for timing.
    #3
  4. murdog94

    murdog94 New Member

    Joined:
    Feb 20, 2008
    Messages:
    8,198
    Likes Received:
    18
    THe distributor can however become loose and move causing the timing to come so far out of tolerance that the computer cannot adjust it anymore..
    And as i said be sure to check for play in the distributor..
    Hope this helps some
    #4

Share This Page