1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

pj carriveau ~ new member from Northern Michigan

Discussion in 'Member Introductions' started by pj carriveau, Nov 12, 2011.

  1. pj carriveau

    pj carriveau New Member

    hi from northern michigan
    have a 1995 yukon with 360k had a strange thing happen with temp gauge today
    started jumping from normal operating temp at 180 to 260 and various points inbetween then for about 10-15 miles then back to 180
    and stayed there as normal. has anyone else had this happen? engine ran fine wasn't sure if temp sensor or temp switch needs
    replacing
  2. sgtsjj

    sgtsjj New Member 1000 Posts

    welcome to the club! cant say that ive heard of that happening with the temp gauge, hopefully some one will be along here shortly that can help you out
  3. dsfloyd

    dsfloyd New Member ROTM Winner 1000 Posts

    welcome to the club. try posting it in one of the tech question sections. you should get more responses that way
  4. Red Z71 Max

    Red Z71 Max New Member ROTM Winner 1000 Posts

    Welcome to the Club PJ!!!!
  5. retired2001

    retired2001 New Member 1000 Posts

    Welcome to the G M T C !
  6. Caddiac

    Caddiac New Member 1000 Posts

    Welcome aboard PJ!

Share This Page