plz help. key spins freely in ignition

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by dirty max, Jun 29, 2013.

Newest Photos

  1. dirty max

    dirty max New Member

    hey guys I have a 2003 duramax. I parked the truck, turned it off fine everything was normal. went to start it and the key spins freely from off to start with no resistance. nothing lights up or anything like it doesn't even acknowledge that the key is in there. its not a dead battery or power problem, that I know for a fact. it has plenty of power. so what can I do to fix this? do I need a new ignition tumbler?
  2. ChevyFan

    ChevyFan Administrator Staff Member 1000 Posts

    I've never heard of this happening with the single exception of stolen vehicles.

    Did someone break into the truck and try to jack it? Popping the lock with a screwdriver and a hammer is one way to do that. Was there any sign of forced entry into your truck?
  3. Kady

    Kady New Member 100 Posts

    That's exactly what I was going to say. Someone must have tried to sneak away with it, and if that's the case, you're lucky to be stuck with a broken ignition instead of no truck at all.
  4. dirty max

    dirty max New Member

    no no lol there was no break in or anything. I went to the store, turned the truck off. was only in there for like 2 mins, came back out and tried to start it. nothing. had to have my truck towed home..... actually! lol I got to the store, turned the truck off. forgot to roll up my windows, turned the key forward to get power and nothing... went into the store bought my stuff thinking it needed time? lol I dunno. but ya.
  5. shibby2oo8

    shibby2oo8 New Member 100 Posts

    Pull the cylinder out and look for a broken tab or switch.
  6. dirty max

    dirty max New Member

    alright ima go do that right now. r&r looks easy enough. I hope this is the problem lol but im pretty sure it is. cuz I don't even have and spots where the key stops ie. acc, on, and start. cant feel anything there at all. well ill go pull her out n take a look. thanks.

    - - - Updated - - -

    K, so I took the cylinder out. everything seems fine with it. but the next part down the line, that aluminum looking block with 2 sets of wires running to it seems to be the problem. cuz I turned the part at the end of the hole where the ignition cylinder goes into and that part spins freely. it should have off, acc, on, and start.. right? I can spin it around with ease, not stopping anywhere along the way.
  7. ChevyFan

    ChevyFan Administrator Staff Member 1000 Posts

    Don't forget to take a couple of photos of this during the process ... I want to see what you're talking about. I guess it's possible that something broke inside or got gummed up, but I would have suspected that it simply would not have turned, intsead of turning freely. :neutral:
  8. csltrains96

    csltrains96 New Member 100 Posts

    Is there a linkage between the ignition tumbler and the system that runs down the steering column that may have come loose? That may require disassembling the steering column to verify. I had an old '80 Oldsmobile Cutlass Supreme Coupe that that happened to. Had to reconnect a linkage before it would start.

Share This Page