Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Power steering/Brake woes

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by wgwebel67, Dec 28, 2008.

  1. wgwebel67

    wgwebel67 New Member

    Hello all, new to the forum and I have a problem I hope someone can help me with.

    I have a 2001 2500 Subrurban 4x4 with the 8.1 motor. I recently had to replace the power steering pump because the shaft snapped. Since then my power steering and brakes only have the power assist above 1000rpm's as I come to stop signs all the power goes away.

    I'll sure appreciate any input.
    Thanks!
  2. JMoney02

    JMoney02 Epic Member 5+ Years 500 Posts

    Did you prime the pump before driving it, or did you just replace and fill it up? Waht about the hose with the clamp on it, is it tight and the hose down on the tube enough?

    Jeff
  3. wgwebel67

    wgwebel67 New Member

    The pump was primed and I bled the system with a procedure. There are three hoses with clamps on them and they are on far and tight. I can't get any play out of them by pulling on them with my bare hands.

Share This Page