Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Power window malfunction

Discussion in 'General Chevy & GM Tech Questions' started by Straightshooter, Aug 28, 2009.

  1. Straightshooter

    Straightshooter New Member

    My front passenger door's power window will not operate, but it is not electrical. I have had the door panel off and the window seems to get loose and gets in a bind. Are the rollers and/or guides replacable? I can't see any adjustment points that would stabilize the window. There appears to be a lot of "slop" in the window. Anyone had this problem?
     
  2. 2ToNe04

    2ToNe04 Epic Member 5+ Years 1000 Posts

    What year of truck.?


    This is for 03-07 im not sure if the 99-02 are the same.
    Also if you have some White lithium greese laying around, i would greese up the rails where the window travels up and down on. Before you apply anything like whitelithium greese make sure the rail doesnt have any dirt or else its pointless, it will just grind all the time.

    Also there is 2 little clamps that have cushion on them clamping down on the window, you can try and tighten them, i believe its a 10mm socket. 1 bolt on each clamp.
     
  3. Straightshooter

    Straightshooter New Member

    It's a 2004 Colorado crew cab. The two clamps that hold the glass are not loose but you can rock the window back and forth. None of the bolts for the motor are loose. With everything tight, you can grab the window and rock it back and forth in the tracks.
     
  4. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    sounds like it slid out of one of the tracts, or your regulator may be loose. check all the bolts, there should be 4 more besides the bolt to the motor
     
    Last edited: Aug 28, 2009

Share This Page