1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Problems with Keyless Locking System

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by esbmann, Sep 4, 2013.

  1. esbmann

    esbmann New Member

    Just purchased a very nice 2003 Silverado Ext Cab Z71. One owner , 68000 miles. Everything on this truck has worked flawlessly up to now. I have replaced the batteries in both units. The locking button on both units is working fine, it will lock the doors and set the alarm. The problem is with the unlock. One unit doesn't work at all, the other is working on a part time[whenever it feels like it] basis. This is the first vehicle I have ever had with this option, so I first read the owners manual, and then replaced the batteries. Is it that the buttons just wear out and you have to replace the unit, this does'nt make sense to me that the locking button is working fine on both unit's, it's the Unlock. Any help would be greatly appreciated.
  2. RayVoy

    RayVoy Active Member 2 Years 1000 Posts

    I do not know if this info is helpful, but it worked for me on the remote for a previous vehicle.

    The contact surface was dirty under the buttons.

    Open the remote and remove the circuit board, the buttons and the contact surface should be visible. Clean both, use a dry cloth and a pencil eraser. Re-assemble and try.
  3. ChevyBoy2009

    ChevyBoy2009 Rockstar 4 Years 500 Posts

    Im with him^:great:
  4. koolbia

    koolbia New Member

  5. esbmann

    esbmann New Member

    Thank You, I will give it a try, long live GM.

    - - - Updated - - -

    Thanks a bunch, one awesome looking truck there.
  6. esbmann

    esbmann New Member

    Thanks a bunch, it worked .
  7. Pikey

    Pikey Active Member Staff Member 2 Years ROTM Winner 1000 Posts

    Good Call [MENTION=54249]RayVoy[/MENTION]! :great:

Share This Page