rack and pinion

Discussion in 'GM Powertrain' started by 07 redrado, Jan 31, 2008.

  1. 07 redrado

    07 redrado Rockstar

    i have 2k on my truck and the rack is leaking. the dealer said that it is normal for it to "drip a little" but i think that they are blowing smoke. anybody else have this problem. i also put in a dvd player in the dash and bought the $200 wiring harness that says it keeps all the factory functions working but now my TPMS light is on and the display says service pressure monitor system. dealer says that it is becouse of my radio. any help with these issues would be helpful
     
  2. collinsperformance

    collinsperformance Epic Member 5+ Years 500 Posts

    the rack should not leak at all. i not sure on the radio but this seems common for some of the trucks i picked up with non-stock radios. the tire monitor might run thru the radio but i am not too sure.....mike
     
  3. omegafiler

    omegafiler Epic Member 5+ Years 500 Posts

    I'd either talk to the service manager or just go to another dealer for both of those issues. Nothing should leak and I don't see how the stereo/harness is messing with the TPMS unless it's causing a short and messing with the BCM or something. Which they'd still need to prove or have some sort of testing they did, of course. You could also just temporarily put the stock deck back in if you really felt like it. Especially if it started right after you put in that harness...
     
  4. 07 redrado

    07 redrado Rockstar

    the light didnt come on untill the next day, put it in on sun night and tues afternoon it came on, after i had driven it to work and back both days. and it is the biggest pain in my a-- to pull it out and put the stock back in. i have a call in to the company that made the harness and havent heard anything yet
     

Share This Page

Newest Gallery Photos