Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Radio reception SUCKS!

Discussion in 'Audio, Video & Gadget Tech' started by Blue05LT2, Feb 21, 2011.

  1. Blue05LT2

    Blue05LT2 New Member

    So my radio's reception is pretty spotty @ best. Some of my local stations come in, but anything over 102.1 is just fuzzy static & the ones that do come in go in & out & are usually little staticky @ best. AM stations I get nothing @ all. I tried swapping decks with a friends that I know works fine & still the same. Is there like a receiver box or something for the AM/FM like there is for the XM? Would it be the box behind the passenger airbag under the dash that has a Motorola label on it?

    I have the Bose system without Navi, has the in dash 6 disk stock deck with XM & the stock DVD system in the back. It's in a 2005 Tahoe LT. The XM comes in fine & the CD player works, speakers are fine. The antennas are there & unharmed.

    Thanks,
    Greg.
     
  2. FrigginNoodles

    FrigginNoodles Rockstar 3 Years 500 Posts

    I would start with checking where the antenna wire plugs into the back of the stereo to make sure it is plugged in all the way. Hopefully it just isn't tight or something. If not I'm not sure what to check next.
     
  3. Blue05LT2

    Blue05LT2 New Member

    Yup tried that several times & even put in another deck & same thing. Thanks though.
     
  4. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Check the ground for the Antenna too.. Some times it can rust and brake or if you had the fender replaced from a crash the body shops forget to put the wire back on...
     
  5. Blue05LT2

    Blue05LT2 New Member

    Being that it's an '05 & has that little nub of an antenna on the roof, where would the ground be? I pulled the headliner down & it was all good under there.
     
  6. jreagan

    jreagan Rockstar

    The small antenna on the roof is XM only. Don't you have a mast antenna at the right corner of the hood near the passenger side?
     
  7. Blue05LT2

    Blue05LT2 New Member

    Nope, I have 2 black nubs on the roof. A square onee on the right (XM) & a plastic thing with a little 3-4" screw on nub (radio) to the left.
     
  8. troutbug

    troutbug Rockstar 100 Posts

    One of those should be for the factory XM and the other should be for the Onstar. I don't think they started combining those to one antenna until 2006, IIRC. You should still have the rightside mast antenna as jreagan said.
     
  9. Blue05LT2

    Blue05LT2 New Member

    Well, I feel like a freaking retard. So I took the plastic cover off @ the base of the winshield on the passenger side & guess whats staring @ me? The base of the antenna! I don't know how or why, but the antenna is gone & someone put a cover over it from an '06 i'm guessing because there's no hole for an antenna to go through.

    Thanks guys, for leading me in the right direction, even though I feel like a total jacka$$ now!

    Thanks,
    Greg.
     
  10. troutbug

    troutbug Rockstar 100 Posts

    Haha, everyone's allowed one of "those moments" from time to time. Just don't make a habit of it!:na: Glad you got it figured out.
     

Share This Page