1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Rear Blower Motor Problems.

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by Murfdogg's95, Dec 14, 2009.

  1. Murfdogg's95

    Murfdogg's95 New Member

    Hey guys. New to the site and so far love all the info. I just picked up a 95 burb with 77k miles. It's in excellent condition except for the paint peeling off in spots. It was a one owner and well kept. The problem I am having is with the blower for the rear a/c and heat. When I turn the truck off the rear motor keeps running on low speed. The only way I can make it shut off is by pulling the fuse under the hood or disconnecting the battery.:grrrrrr:

    At first I didn't know what was causing the battery to die and after going out and getting a new battery and having the same issues I started lookin and found the blower motor still running. Does anyone have any ideas as to where to look. I have a strong automotive background so repair shouldn't be a problem just wondering if anyone has any clues.

    Is there a relay for the rear controls that I should look for????
  2. Murfdogg's95

    Murfdogg's95 New Member

    Just a quick update: the blower hasn't given me any problems the last few days but I am still confused as to what the problem is. If anyone else knows anything please feel free to give me some tips....

Share This Page