1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Rear view mirror keeps "resetting" 05 yukon xl

Discussion in 'GM Electrical Tech' started by Pikey, Jan 31, 2013.

  1. Pikey

    Pikey Moderator Staff Member 2 Years ROTM Winner 1000 Posts

    I noticed a few weeks ago that my rear view mirror keeps "resetting". When it does this it looks like it does when you first start the truck. The compass and temp display ***, the green power light turn on and off, and the passenger airbag "on/off" lights also turn on/off. It only did it a few times and stopped. I have not noticed it again until today. It started doing it every 5 minutes or so. I am wondering if this is a common problem and what the cause may be! My 03 Yukon XL did the same thing. On that truck it was consistent with it being hot outside (above 85 degrees) and when it would "reset" it would do it constantly. When it was cold out it would act as expected. Could it be the temp sensor? Any other ideas? Thanks
  2. Zzyzx

    Zzyzx Member

    Well, I know, rarely, when the temperature gets very cold outside (ice forming on the truck,) my mirror will sometimes shut off completely until it gets warmer. It's only happened maybe 6 times, and I think that was all in one or two road trips. I wonder if too much water/ice in the temperature sensor might short something that shuts it down until it's cleared out? I'm not sure myself. I wish I had more advice, but I haven't really bothered with the issue, since it doesn't happen normally. Granted, it's a lot colder in Michigan, so I thought that might contribute. Good luck!
  3. Cheez

    Cheez Rockstar 3 Years 100 Posts

    I've never had an issue with mine resetting. It has forgotten which way is North though. Simple recalibration fixed that though.

Share This Page