Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

replaced HU still doesnt work HELP

Discussion in 'General Chevy & GM Tech Questions' started by hondaaccord1991, Mar 29, 2009.

  1. hondaaccord1991

    hondaaccord1991 New Member

    I have a 2004 Chevy [COLOR=blue ! important][COLOR=blue ! important]Suburban[/COLOR][/COLOR] fully loaded with the bose system. About 2 weeks ago the stereo was acting up and if you would crank the bass there wouldnt be any at all. It did this for about a week and then randomly there was no sound output at all. If you turn everything up there is still no sound. I checked the amp and stereo fuses and they are fine. Also when you turn on the rear stereo controls every speaker in the [COLOR=blue ! important][COLOR=blue ! important]car[/COLOR][/COLOR] pop very loud. I replaced the HU with the same kind from my friends 03 H2 and the speaekers will randomly pop without the key in the ignition and the stereo says lock. Can i use the HU from the hummer and just have it reset or what. the H2 HU is part #15198715 and the REM# is 12229245
    Please help me
  2. 04blackz71

    04blackz71 Rockstar 100 Posts

    sry to hear about you radio i am not sure if you can use te hummer one or not the easy way is et an after maket or one from a junk yard that still works
  3. hondaaccord1991

    hondaaccord1991 New Member

    yeah thats what i thought but then i would loose rear stereo controls and the dvd controls. thats what happened in my old expolder
  4. blueZ71

    blueZ71 Rockstar 100 Posts

    I know hey have some sort of anti theft mechanism which is probably why it says lock. Sorry I'm not more knowledgable but I hope this points you in the right direction.

Share This Page