Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Rough Country Level Kit Now random clunk/pop passenger side

Discussion in 'Lifted & Offroad Suspension' started by torqydd, Mar 28, 2011.

  1. torqydd

    torqydd Rockstar

    Alright fellas I am out of Ideas with this one. Okay 2008 Chevy z71 xcab installed RC 2" leveling kit about 3 weeks ago and now have developed a random clunk/pop on the passenger side of the truck or so it seems its on that side. It can be felt in the floor board. I have checked and rechecked all the torque specs to make sure nothing has come loose. The thing is it only happens when backing up turning wheel with a little brake pressure, when pulling forward with wheel turned. I am completely stumped on this one. Doesn't do it driving down the road or stop and go traffic with turning involved. Can make it do it bouncing it while parked or rocking it side to side. Nothing appears to be in a bind, so at this point i am a bit lost on what to check. Almost thinking taking it all back apart and starting all over but thought I would come to you guys and see what your thoughts on it might be. :neutral:
  2. jbjohnson92f

    jbjohnson92f Rockstar 4 Years 500 Posts

    very weird, i have the same kit and no issues
  3. torqydd

    torqydd Rockstar

    Well it was buggin me this morning so went out side for one more check and was just looking around and noticed the sway bar link and looked at the amount of thread showing from the driver to the passenger side. Driver side had about an inch of tread showing and passenger had 1.25 to 1.5. So maybe in my frustrated state of mind i ended up over tightening the passenger side putting some bing on it, not sure. So backed it off to match the driver side and we will see.

    Just out of curiosity jbjohnson92f if you get a moment would you peek at yours and see if you have more than an inch showing on the sway bar link threads.
  4. Runnerboy23

    Runnerboy23 Rockstar 100 Posts

    Yeah I have the same kit and the same problem it seems to come and go though. Does anyone know what it could be?
  5. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    I think I read sometime ago on this site that RC had a recall on one fo there kits, they had redisigned it. I'd give them a call and see if this is the kit.
  6. jbjohnson92f

    jbjohnson92f Rockstar 4 Years 500 Posts

    i just watched an install video on youtube and it looks like its only about an inch of threading
  7. clgoch187

    clgoch187 Rockstar 4 Years 500 Posts

    are your torsion adjusters cranked all the way? if so back em off a bit
  8. torqydd

    torqydd Rockstar

    Well hmmm the search continues the mysterious pop/clunk. May just have to tear it down and redo everything

    ---------- Post added at 06:12 PM ---------- Previous post was at 06:10 PM ----------

    Its the full independent with coil over no torsions.
  9. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    I would give RC tech line a call. May save you alot of hassle.
  10. torqydd

    torqydd Rockstar

    Yeah I made one more attempt at the tech line. I did end up with a pretty knowledge able guy. This is what he told me for anyone else that might be having the same issue. jack truck up go through all nuts and bolts loosen them drop truck on its on weight and re tighten everything back to specs. Pay close attention the the sway bar links as there should be only an inch of thread showing from the top of the nut to the top of link bolt. He felt the popping could have been coming from over tightened sway bar links causing a binding issue resulting the pop under various loads. As of right now time to get the tools out and got to town on everything. Maybe this will fix if not might just have to live with it or take it to the chevy house

Share This Page