1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

rough idle, hesition, dieing, no start

Discussion in 'GM Powertrain' started by JoshOzan08, Jun 15, 2010.

Random Gallery Photos

  1. JoshOzan08

    JoshOzan08 New Member

    I have a 2000 Chevy Silverado 1500 with a 4.8L V8. for the past six months it has been idleing rough, and when you give it gas to take off it hesitates sometimes also when cruising when you give it a lil gas to pick up a few mph it jerks. someone told me it was the fuel pump so i changed it, nothing changed problem was still there. so i tried seafoam, didnt help, the day after i changed the fuel pump i was on my way to work and it died going down the interstate. after about 5 or six tryes it started but ran horible and died. cranked it one more time and gave it a lil gas then it stayed running. a couple of days later im on my way home from work pulled up to a red light but when i took off it stutterd and died and now if wont crank at all. please help!!!! i am mechanically inclined so if i can get so testing proceedures im all ears thanks
  2. MrShorty

    MrShorty Moderator 1000 Posts 100 Posts

    I would probably start with some basic diagnostics: Even with the new fuel pump, I'd put a fuel pressure gauge on it and see what fuel pressure is doing, I'd probably put a scanner on it to see if there are any pending codes or other information, check for vacuum leaks.
  3. k.daddy1

    k.daddy1 New Member 100 Posts

    pull the vaccuum line off the fuel pressure regulator at the top of the motor. If you have gas coming out of the vaccuum line, your F/P regulator is bad. That will cause your low idle, rough running, etc. Just something to check.
  4. JoshOzan08

    JoshOzan08 New Member

    fixed one problem

    i fixed the the no start problem now to handle the rest
  5. MrShorty

    MrShorty Moderator 1000 Posts 100 Posts

    This forum is all about gathering information to help us all resolve these issues. Would you care to describe what fixed the no start and how you diagnosed the problem?
  6. JoshOzan08

    JoshOzan08 New Member

    the fuel pump connector was loose. when i wiggled it it ran so i pulled the bed and saw the connector was loose

Share This Page