Rough Idle in Chevy Colorado Pickup

Discussion in 'Chevy Colorado Forum (GMC Canyon)' started by lilmissme, Oct 16, 2007.

  1. lilmissme

    lilmissme New Member

    I need some help!!! This is my second go round with problems on my 2005 z71 ls crew cab I5 engine. At approx. 35,000 miles the dealer had to replace all valves, valve springs, a piston and the head. Now at 75,000 miles I have a horribly rough idle. The OBD II reads LOW RPM AT IDLE, and when coasting the engine cuts off. If I sit idling the truck vibrates badly. When the car stalls I have a difficult time getting it to the side of the road to stop and restart. I havent taken it to the dealer yet because if it is not covered under that new 100,000 mile warranty I cant afford to fix it. I am desprate please help me!
     
  2. Flatman

    Flatman Rockstar ROTM Winner 100 Posts

    Your best bet is to just take it in and see what they say... Here's hoping for the best!


    Good luck.
     
  3. WestCoastColy

    WestCoastColy Rockstar ROTM Winner 100 Posts

    I had similar symptoms on my 2005 truck when it was still relatively new and only had 6,000 miles on it. It turned out to ba a bad o2 sensor caused by a loose wire in the MAF sensor harness. Once the o2 sensor was replaced and the wires in the MAF sensor plug straightened for better contact, all has been well. I also replaced the plugs at 15,000 miles to Denso Iridium plugs and it idles even smoother. I now have 62,000+ miles and it idles and runs great.
     
  4. ChevyFan

    ChevyFan The Sheriff Staff Member 5+ Years 5000 Posts

    Is this a common issue?
     

Share This Page

Newest Gallery Photos