rough idle

Discussion in 'General Chevy & GM Tech Questions' started by RLawns, Jan 27, 2009.

  1. RLawns

    RLawns New Member

    i have a 93 z71 with a 350. I was driving one day and it has a really rough idle and almost stalls. so i changed the spark plugs and noticed the driver side was running rich and the passanger side was running lean. What would cause this? I also changed the plug wire,cap and rotor but did not help. any suggestions??
    Thanks
     
  2. cascott325

    cascott325 Epic Member 5+ Years 1000 Posts

    fuel pressure, misfire, timing?
     
  3. RLawns

    RLawns New Member

    its is misfiring. I havent checked the fuel pressure yet. it stops misfiring when i am going 70 mph.
     
  4. jlsparky7

    jlsparky7 Rockstar

    Exhaust leak causing the comp to dump more fuel?
     
  5. k.daddy1

    k.daddy1 Rockstar 100 Posts

    When you say the left side is running lean, does it have a crust build up on the electrode? These trucks have a history with the intake gaskets, especially on the left side. Have you had to add coolant recently? If so, instead of a fuel related problem, you may have an intake gasket leaking fouling the plugs. Just a hint, I've replaced dozens of those gaskets for the same reason, rough idle, miss, etc.
     
  6. mrfixdit

    mrfixdit Rockstar 100 Posts

    I agree with k.daddy1, have you had any check engine soon codes, specifically a p0300 ?
     
  7. JMoney02

    JMoney02 Epic Member 5+ Years 500 Posts

    Definitely and are there codes as asked? Several issues were relate to this incident and its not the standard tuneup parts. What have your specifically changed recently? At 70mph it smooths out, but when you idle do here a "Vaccuum leak" or a unusual sucking sound?

    Jeff
     
  8. jhc

    jhc New Member

    Same rough idle with my 99 Suburban

    Same rough idle with my 99 Suburban and the P0300 code keeps popping up. Plugs, wires, cap, have all been changed.
     

Share This Page

Newest Gallery Photos