1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!
  1. Stl_Denali

    Stl_Denali New Member

    Recently noticed a problem with my RPM’s fluctuating by a couple hundred when h9olding the pedal steady at 40 to 45mph, right under 1500 RPM. It feels like it would if you were slightly pumping the gas pedal. –not so much a stutter.

    It’s a 2005 Yukon Denali 6l. I have cleaned the throttle body but it hasn’t helped the issue. (though it did help the reaction time). I have a RAM air and predator tune since 06, but this recently started happening.

    Any suggestions or past experiences with this would be an awesome help!! Thanks!!!!
  2. TELORVEHC

    TELORVEHC New Member 1000 Posts

    Could a number of things. When was the last time you changed your air filter? How old are your spark plugs & wires?
  3. Stl_Denali

    Stl_Denali New Member

    Plugs and wires were changed at 100K, about 20K ago... Air filter has just been changed. - The custom one for the Hood is the only one that realy gets dirty, the stock one always looks good but still gets cleaned). Both are K&N.

    Could it have somthing to do with the MAF sensor? The little gauge that shows how dirty it is or what ever has never moved.
  4. TELORVEHC

    TELORVEHC New Member 1000 Posts

  5. Stl_Denali

    Stl_Denali New Member

    Cool, will try (when its not 110 degrees out) and update.

Share This Page