Running rich problem

Discussion in 'Performance & Fuel' started by ftms, Jun 5, 2010.

  1. ftms

    ftms New Member

    Hey guys i am new here and not sure if this has been brought up before but i will take my turn asking. I just finish installing a brand new 350 crate motor. I put on hooker headers, magna flow high flow cats, and flowmaster 50 series mufflers. the headrers only had one bung for an O2 sensor. The sensor is a single wire. The truck is running super rich....really strong smell and lots of fuel coming out the pipes...what can i do?????
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Year make, model would help a lot.:great:
     
  3. ftms

    ftms New Member

    sorry forgot that part

    1993 GMC YUKON GT
     
  4. ftms

    ftms New Member

    originally it was two into one with a single O2 sensor
     
  5. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Coolant temp switch could be bad. You might have a buble un the intake allowing the temp sensor to think everything is cooler than it is. Also Do you have the timing right??
     
  6. ftms

    ftms New Member

    I replaced all of the sensors when i put the new engine in. The timing was set this afternoon....now with that i was told to set it to 0 degrees and the computer would take over the rest. Now i did notice when setting it the timming was a little jumpy when rev'ing it up. the ignition set up is all new Mallory ignition parts.
     
  7. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Hmmm... To be honest youve got me.. Is it still a TBI???
     
  8. ftms

    ftms New Member

    yea it is......I wasn't sure if i need to put a second O2 sensor on the passenger side exhaust.....or put a y pipe back it, or what....its got me scratching my head too!!!!!
     
  9. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    In all reality the O2 sensor shouldnt cause it to run that rich... Did you do a rebuild on the TBI?? when you put it in?? Also did you clean out the EGR??
     
  10. scrappiedew1

    scrappiedew1 Rockstar

    the engine cntrol pc might be looking for that other 02 sensor
     

Share This Page

Newest Gallery Photos