1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

s10 blazer electrical problems

Discussion in 'Chevy Blazer Forum (GMC Jimmy)' started by moneypitt, Dec 14, 2009.

  1. moneypitt

    moneypitt New Member

    hello
    i have 93 s10 blazer 4 door 4x4 5 speed, i have noticed that when i go over some bumps in the road, all of my electricial cuts out. an example is my lights, ignition, my idiot lights come on. i have the base model no power windows or cruise control. any help or suggestions would help me out a lot.
  2. skgs10blazer

    skgs10blazer New Member

    I'm having similar problems with my 1999 S-10 Blazer. I've noticed occasional different little things like the odometer/trip meter kink of flickering, automatic door locks not working. Last night when I started the car it was a little slow to come to an idle. When I drove off all the idiot lights we on or blinking, but went back to normal after a bit. This afternoon I can't start the car. It's like the battery is dead, but then a few things would work, like the radio display, radio anti-theft light, when I jiggled the ignition. The door locks don't work, I'm going to try to jump start it when my husband gets home, just to make sure it isn't the battery. I hope we an answer.
  3. unplugged

    unplugged New Member 1000 Posts 100 Posts

    A couple of things come to mind. Since a bump in the road seems to trigger the event, I'd check you battery ground and the ground between the engine and the frame. Just in case, I have to ask if the battery is secured properly? A battery bouncing around can momentarily disconnect especially if the terminals are loose or show corrosion.

    Lastly I check the dashboard grounds.

    Let us know what you find.
  4. moneypitt

    moneypitt New Member

    Hello I have solved the problem, my air cleaner was hitting my altenator and shorting everything out. We put some tape on both of them and no problems. : )

Share This Page