1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Security system/engine not starting

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Trask215, Mar 7, 2009.

Random Gallery Photos

  1. Trask215

    Trask215 New Member 100 Posts

    My '01 silverado has recently had the trouble of not wanting to start. I will turn the key until it catches then release as normal. However, the engine fires for about a second or two and suddenly dies. It doesn't do this all the time. If I fiddle with it for awhile or sometimes let it sit for awhile it usually starts. Sometimes when I am driving the security light will come on and stay solid. My mechanic says he thinks it's a security relay going out or something that cuts the fuel. Any ideas?
  2. Jimmiee

    Jimmiee New Member 1000 Posts 100 Posts

    Mike,

    It sounds like a security system issue. The PCM will cut power to the fuel pump if it sees a problem. See if there are any security system codes stored in memory.
  3. ukrkoz

    ukrkoz New Member 100 Posts

    this is a well known and ongoing issue with GM security system installed on the truck. BCM - body control module - for whatever reasons thinks that truck is being stolen and shuts down fuel pump.
    there's specific procedure for resetting security system in cases like this. google it, it is well known on the web.
    also, do you have chipped key? bad key will do it.
  4. Ryancbennett

    Ryancbennett New Member

    my 03 silverado does the exact same thing. i have an aftermarket audiovox remote starter on it and it does it all the time. i took it to a local audio shop and they said that some of the wires were not sodered enough. they fixed it but my security light still comes on every now and then. i took it to a local dealer before that and they said that my pass lock needed to be replaced and that was about 600 dollars. but now when i turn the key, 3 seconds later the doors lock. but the starting problem has seemed to have gone away. i would take it to a audio store that installs stuff like that and have them check the wires on your security system. good luck...
  5. Trask215

    Trask215 New Member 100 Posts

    So I took my truck to the dealership on monday, they called and told me that they couldn't get the truck to duplicate the problem for them (always happens when you need to get somethin fixed). Anyways, the computer stored a trouble code telling them to reprogram the passlock computer. They did, $80 later it is working now and I haven't had any problems with it. I would have tried to reset the computer myself but didn't in case there was something else wrong with it, I wanted it to happen again for the dealership. O well, I'm just glad to have my truck fixed and back.
  6. Bluewater

    Bluewater New Member

    key

    If you have had a new key made lately that may be the problem too. If they are not cut exactly right the computer thinks someone is stealing your rig.
  7. Trask215

    Trask215 New Member 100 Posts

    Well I bought the truck used, and so I have never had the original key. I did have a spare made which is what I've been using for the past 6 months or so. So I don't know what made the computer glitch or whatever.
  8. ukrkoz

    ukrkoz New Member 100 Posts

    friendly advice - next time, before you give 2 tankfuls worth of money to dealership, google the issue. monkey can do passlock reset, basically, you just set the key into specific position and do some dashboard on/off procedures.

    also, to the guy that has remote start installed. remote starts installations require passlock to be disabled. you can go to any major remote start maker website and they have posted proper wiring diagrams, etc. also, some of them sell passlock bypass modules. whoever had your remote start installed, should have done this.

    http://www.car-forums.com/s10/t19652.html
    http://www.burnyourbonus.info/rec.autos.tech/thread610.html
    and g'ol GM itself:
    http://www.gmupfitter.com/publicat/bull/bull26.pdf:rules::party:
  9. egreg

    egreg New Member

    I'm having the same problem and I do not have a remote start installed. I was messing around with some things under my dash and I think I triggered something in the BCM which has enabled the anti-theft feature. Now my truck will turn over, but will not run. What can I do to bypass this annoying problem without the rewiring technique that was mentioned in the previous post?
  10. egreg

    egreg New Member

    I'm bumping this because I am still having the issue. I'm having my BCM reprogrammed at the moment. Hopefully it will resolve the problem. Any other ideas on how to bypass this anti-theft feature?

Share This Page