Sensor on intake manifold

Discussion in 'Chevy C/K Truck Forum' started by okysmokey911, Oct 12, 2009.

  1. okysmokey911

    okysmokey911 Rockstar 100 Posts

    Today I was detailing my engine and I was cleaning all of the plugs that go into the different sensors on the engine and one broke off completely. This was at the front of the intake manifold and had water coming out of it. I feel dumb for not knowing what sensor this is haha but that is what these forums are for. Any help would be greatly appreciated. Engine -93 5.7 350 tbi
     
  2. okysmokey911

    okysmokey911 Rockstar 100 Posts

    Ok I figured out what it was. The water temperature sensor. Damn thing just broke off.
     
  3. unplugged

    unplugged Epic Member 5+ Years 1000 Posts

    Some of the connectors on my 93 are going south too. I found the temp sensor connector at NAPA and spliced it on to replace the broken one. There was one up on the intake that I couldn't find so I used some electrical tape to secure it.
    Check out this place if you can't find a local source: http://www.repairconnector.com
    [​IMG][​IMG][​IMG]
     
  4. okysmokey911

    okysmokey911 Rockstar 100 Posts

    Thanks for the website. I have a few connectors that are going bad. One in particular is on the drivers side of the engine that screws into the head. What is that sensor for? It leaked water as well when I unscrewed it.
     
  5. TRPLXL2

    TRPLXL2 Epic Member 5+ Years 1000 Posts Platinum Contributor

    All of those connectors that unplugged showed they sell at Summit Racing, you can either buy them already assembled or you can make your own. I make all of my own connectors and they are the same as the factory one's for about 25% of the cost of the pre-manufactured one's, all you need is the MSD crimpers with the Metri-Pak dies and your all set to make as many as you want.
     

Share This Page

Newest Gallery Photos