Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Service 4WD Warning ~ 2001 Suburban

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by ecfune, Nov 12, 2012.

  1. ecfune

    ecfune New Member

    The message center (dashboard warning) displays SERVICE 4WD on my 2001 Suburban 1500. I do not hear anything unusual to cause the light. I do not know what to check. Please help.
  2. Pikey

    Pikey Moderator Staff Member 2 Years ROTM Winner 1000 Posts

    I had the same warning come up on my 03 Yukon Xl. I crawled under the truck and started unplugging and replugging in connectors. Luckily, that fixed it. The connector to the encoder motor was corroded. I would start by trying that. Are the lights on your 4x4 indicator on or all off? Unfortunately, most cheap scan tools can not check the codes associated with the 4x4 system, so a Tech II is needed to tell you exactly what the issue may be. You might be able to find a shop near you that has one or a snapon model that can read your codes cheaper than what a dealer would charge. I believe that the 00-06 models have known issues with the encoder motor going bad. But, before you throw parts at it I would have it scanned.

Share This Page