1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

service 4wd

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by redneckarmyMP, May 22, 2009.

  1. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    anybody know what this thing is tryin to tell me?my 04 silverado 4x4 sees some mud from time to time and every now and then after i shift into 4wd ill get a message sayin service 4wd.anybody know what this is tryin to tell me and is it hard to do my self?
    thanks
  2. poncho08

    poncho08 Rockstar 100 Posts

    I get the same message when I shift from my four-wheel drive in 40 below weather. I don't think it's a big thing because it goes off after a little while eaven my Chevy dealerships sead don't worry about it but when it comes to mud I don't know?
  3. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    when it happens it wont let me shift back to 2wd or 4 low.i have to turn the truck off wait a second start it back off and then shift.im thinkin maybe low diff. fluid but im not sure.ive also noticed it mainly happens going up or down an incline
  4. 12pack

    12pack New Member

    I don't know if this will help but I posted in the Powertrain section about a fix for the push button 4x4. How to reset the 4x4 computer. Pull the 4x4 fuse and turn the key to the on postion ( DON'T START JUST THE ON POSITION) and back to the lock position 5 times slowly.Then replace the fuse and try your 4x4 push buttons. This will reset the 4x4 computer. This fixed my 2003 Avalanche when it would go into 4 LO and be stuck there. Don't no if this will help your problem but I thought I'd just though it out.
  5. MrShorty

    MrShorty Epic Member Staff Member 5+ Years 1000 Posts

    When you get the service 4wd message, that means the transfer case control module (TCCM) has detected some kind of fault. By the book, you would hook up the system to a scanner that can talk to the TCCM and ask it what problem it is seeing, then diagnose from there. Resetting the system, as suggested may help. If the problem keeps recurring, then you should take the time to get it fixed.

    If you end up "guessing" at the problem, two common areas seem to be the most common problems: the switch (seems to be more applicable to the late '90's/early '00's) or the shift module on the t-case (later years).
  6. 97chevz71

    97chevz71 Rockstar ROTM Winner 100 Posts

    My dad has a 04 and what happen is the computer in the truck bascially goes to sleep. if you get the computer rebooted it will work fine.
  7. Montana

    Montana Member

    Our trucks see alot of mud also. We get these messages from tiem to time. Usually it is the plug is dirty and the computer loses signal to the transfer case. Try cleaning your connections underneath. Otherwise, it could be the encoder motor in the TC.

    HTH
  8. redneckarmyMP

    redneckarmyMP Epic Member 5+ Years 500 Posts

    sorry it took me a while to get back to yall.i been a little sick.but thanks for all the help..ill try to reset the computer and clean up those connestions and go from there.thanks again!
  9. liv2hunt

    liv2hunt Member

    Mine does that after I take it out of 4 wheel . It will say service 4 wheel drive about 5 times. Than after a while when I start the truck it will be in 4 Low. When I take it out of 4 low it is fine till the next time I put in 4 wheel.

Share This Page