1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Service engine code 174

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by lancer, Oct 20, 2011.

  1. lancer

    lancer Epic Member 5+ Years 500 Posts ROTM Winner

    hey guys went and got gas tonight and went to walmart. when we came out started the truck to leave and soon as i put it in drive the service light came on. we took it to autozone to use their free scanner and it said 3 codes 171 and 174 twice. the print out they gave me says lean bank on one and two and MAF sensor. hasn't anyone else had this trouble?? its a 2002 tahoe 5.3 vortec flex fuel. i called the local autozone and they have one sensor instock for $80 with a $60 core with a year warranty. my question is should i go buy the new sensor and try it or take it to the shop and see what they have to say???
     
  2. 99'HEARTBEAT

    99'HEARTBEAT Epic Member Staff Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    For Both Trouble Codes.....P0171 and P0174.........may mean that one or more of the following has happened:


    • The MAF (Mass Air Flow) Sensor is dirty or faulty. Note: The use of "oiled" air filters may cause the MAF to become dirty if the filter is over-oiled. There is also an issue with some vehicles where the MAF sensors leak the silicone potting material used to protect the circuitry.
    • There could be a vacuum leak downstream of the MAF sensor.

    Edit.....A Cleaning of the MAF Sensor with......CRC's MAF Sensor Cleaner.....the 1 in the Silver Can......is most likely going to Correct the problem.
    [TABLE]
    [TR]
    [TD][/TD]
    [TD][/TD]
    [/TR]
    [/TABLE]





    [​IMG]

     
    Last edited: Oct 20, 2011
  3. lancer

    lancer Epic Member 5+ Years 500 Posts ROTM Winner

    thanks 99heartbeat i'm going to try and get some maf sensor cleaner tomorrow and trying cleaning it before i replace it. also found a friend that has an actual code scanner so we are going to run it tomorrow night..
     
  4. 99'HEARTBEAT

    99'HEARTBEAT Epic Member Staff Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor


    Let us know what happens......also take your time and be careful when cleaning the MAF Sensor, as it can be easily Damaged.....
     
  5. lancer

    lancer Epic Member 5+ Years 500 Posts ROTM Winner

    i took it to the car lot we bought it from yesterday morning and my buddy mechanic that works there scanned it and said it could be a few different things but not to worry about it. he cleared off the code and said if it comes back on bring and they'll look alittle harder. i cleaned the maf sensor with the cleaner when i got home. didn't look too bad but i don't know what a really dirty one looks like. we drove it 3 hour round trip last night and the light never came back on so i'm hoping it was just a fluke code and won't have anything to worry about...
     

Share This Page