1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Service Engine Light And Transmission Issue

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by cjspga, Mar 29, 2013.

  1. cjspga

    cjspga New Member

    Service Engine Soon light has come on and since the transmission on my 97 Suburban 4X4 doesn't shift into 4th overdrive ? Seems I have gone from 2000rpm at 70mph to about 2000rpm at 65mph since it came on.

    Make any sense to anyone ?

    Thanks - Chris.
  2. Big_Mike

    Big_Mike New Member 100 Posts

    Few questions for you Chris (welcome to the site by the way, see you're a "newbie"). Do all the other gears in the transmission work? First and second? You don't just start have third? And you need to hook a scan tool up to it or have a mechanic do it. That way you can have an idea of what may be at fault. Sorry but that's about all I can say without more info...
  3. TRPLXL2

    TRPLXL2 New Member Platinum Contributor 1000 Posts 100 Posts

    Welcome to the club!!!

    Well since your not able to shift into overdrive, I would say TCC solenoid in the transmission valve body. (Torque convertor control) solenoid. It will not damage the transmission, It will just run at a higher rpm, and your cruise control won't work either.

Share This Page