1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Service Stabilitrak, Service Traction Control, and Reduced Engine Power -- anyone?

Discussion in 'GM Powertrain' started by mjs84, Dec 14, 2010.

  1. devil_doc7721

    devil_doc7721 Member

    I appreciate the help man. Yea it rained the last few weeks down here so that could be it i never thought about that so i will definetly give that a look next time it happens.
  2. ahmitchell1

    ahmitchell1 Rockstar 4 Years ROTM Winner 1000 Posts

    Anytime. Just noticed you were from Pensacola, I was down there a few weeks ago with the now ex gf and it was pissing rain. Try and find out where the water comes in and seal it up
  3. devil_doc7721

    devil_doc7721 Member

    yea its rained alot down here lately its the season lol. and ill try to figure that out and seal it up if thats the problem
  4. ahmitchell1

    ahmitchell1 Rockstar 4 Years ROTM Winner 1000 Posts

    Good news I got a letter in the mail and if your having this problem get your truck to the dealership instantly. They will reimburse you for anything you had to pay fixing it and also fix the problem if it is not yet.

    As far as I know it's only for silverados NNBS
  5. devil_doc7721

    devil_doc7721 Member

    That would be sweet cause mine is going off everday everytime i start up and wont stop and i really dont have the money to fix it. hopefully my dealership down here got that message. thanks for the heads up ahmitchell1 that will definetly help alot of ppl out.

    - - - Updated - - -

    so i think they are just hooking you up or something because my local chevy dealership said they had no idea about what i was talking about. that they hadnt heard anything about fixing the problem for free or anything like that. did you write chevy or something?
    Last edited: Feb 1, 2013
  6. dspaulding

    dspaulding New Member

    Evan, My 2012 Silverado had been having an occasional issue with the Traction Control and Stabilitrak being turned off and the warning messages as well as the proverbial "idiot" lights coming on. At first these occurrences seemed to be primarily on colder (but certainly not slick) days and the duration was short, normally happening only once or twice on the 30 minute drive in to work. Recently the warnings have been coming on numerous times with a very noticeable loss of power and the hard clunky shifting of the transmission. The last two days it happened repeatedly on the trip to work and the loss of power was very noticeable. I have also had the engine just up and die on me a few times as I was trying to enter traffic which I find to be extremely dangerous here in Houston and quite alarming. This is an unacceptable situation which could certainly lead to a bad accident trying to get onto the two lane road leading that serves as the exit for our subdivision. I have left a message for my service guy at the dealership but, I can tell you from the obvious long term existence of this TCS issue for GM and the description of how the customers experiencing this issue have been treated... I am very concerned! I can tell you that I had absolutely no issues with my 2007 (non GM) truck and sold it with about 100,000 miles when I got this truck. I only have 18,000 on this new truck and had begun having issues since 7,000 miles or so. It seems some of the reasons quoted for this problem should just not be an acceptable performance standard...blaming a lot of rain for causing such serious issues with a modern vehicle just seems way over the top. I have never had any such problems with numerous other personal vehicles and trucks.

    Last edited by a moderator: Jun 24, 2013
  7. dspaulding

    dspaulding New Member

    My 2012 had been having an occassional issue with the Traction Control and Stabilitrak being turned off with the accompanying warning messages as well as the proverbial "idiot" lights coming on. At first these occurrences seemed to be primarily on colder (but certainly not wet or slick) days and the duration of the event was very short, normally happening only once or twice on the 30 minute drive in to work.

    Recently the warnings have been coming on numerous times with a very noticeable loss of power and the hard clunky shifting of the transmission while in this status. The last two days it happened repeatedly on the trip to work and the loss of power was very noticeable. I have also had the engine in this truck just up and die on me a few times as I was trying to enter traffic which I find to be extremely dangerous here in Houston. This is an unacceptable situation which could certainly lead to a bad accident trying to get onto the two lane road leading that serves as the exit for our subdivision. I have left a message for my service guy at the dealership but, I can tell you from the obvious long term existence of this TCS issue for GM and the descriptions posted on some blogs on this issue about how the customers experiencing this issue have been treated by GM and their dealer network... I am very concerned that this may become one of those ongoing issues!
    Last edited by a moderator: Aug 27, 2013
  8. devil_doc7721

    devil_doc7721 Member

    so i dont know if this will help anybody out or it just helped me but i have had my service stabiltrack and and traction controld and brake light on for about 2 or 3 months without them turning off at all. but yesterday i noticed i was pretty below the low line on my brake fluid and so i filled it up to the high line and i havent had the lights or anything come on all day while driving. so i duno if this problem is as easily fixed by something stupid like that but it only takes a second to look and see if your low. im sure it wont fix everybodys problems but hopefully it helps at least some of yall out cuz i was bout to finally take it in to the shop this weekend and probably drop a bunch of money on it but hopefully thats the stupid little fix that helps.
  9. tpm8

    tpm8 New Member

    Jcaddy,

    I have a 2009 Suburban w/ 108k miles and 5 months ago on route 85 the traction control just cut off, both the engine and power-train where running rough and underpowered, the indicator lights where rotating service traction control, and reduced engine power. I limped off the interstate pulled over and checked my fluids (fine). When I restarted it was like it never happened, I called my mechanic who said he had not heard of anything like that happening. When I returned to town, I brought it in and he said the code said TBS sensor issue. Since he could not recreate it he suggested I bring it in the next time it happened. Over the next few months once or twice a month (primarily in the morning) The traction control would turn off, my vehicle would run painfully rough, indicating lights (Service Stabilitrak, Service Traction Control, and Reduced Engine Power) would rotate. Because it always happens when I need to be somewhere I would pull over shut down, and after 5 minutes it would reset.

    As fate would have it I was traveling from NoVa to Raleigh when I had to pull over no less than 5 times on the way down. Needless to say I was on the phones with dealers in Raleigh to find service availability and a throttle body:

    Apparently the throttle body sensor must be replaced with the complete throttle body housing and gasket. The repair priced out to: throttle body $280, Gasket $37 and Labor was $125. Unfortunately for me the service depts were backed up 2-5 days depending on the dealer.

    Since I was staying at a hotel, I went to Autozone and had them pull a code again indicating it was again the TBS sensor, I decided that if I had to replace the throttle body anyways, cleaning it couldn't hurt. I purchased a can of throttle body intake cleaner, I removed the plastic housing 2 tension bands on the front of the engine that covered the throttle body, I then sprayed into the throttle body for 30-40 seconds cleaning as much of the varnish off I could. I was surprised when I started up the vehicle and the check engine light was off (i always thought dealers had to reset), and after 4-5 seconds of the cleaner working through, it ran perfectly. I decided I would repeat for good measure.

    That was 2 months ago and I have not had a re-occurrence since.

    I hope this helps
    Last edited: Apr 14, 2013
  10. chipjumper

    chipjumper New Member

    There are several reasons why the vehicle will go into "Reduced Power Mode". One of them is when the TPS detects a position mismatch. Basically if it detects something "funny" with the throttle, it will cut it down. This prevents a runaway throttle condition like the one the F-150's had. Replacing the TB is the only way to repair this specific condition. Obviously the fault can come from a generally failed part and/or electrical fault (bad ground, etc.) to a bad PCM, etc etc etc.

Share This Page