1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

She won,t idle for nothing

Discussion in 'Performance & Fuel' started by BackwodsChevy, Jul 27, 2013.

  1. BackwodsChevy

    BackwodsChevy New Member

    93 model replaced the head gaskets.Got her all together ,but she won,t idle after warmup.I replaced the IAC valve and no difference.No vacuum leaks that I know of fuel pump has been replaced.She runs great other than that.Any ideas or advise would be greatly appreciated.
  2. treitz3

    treitz3 New Member

    If this is anything like my '04, it's the computer and not you or your truck. Hear me out, please. If at any time the battery during your rebuild was disconnected, the system is off kilter. After this happened to me, I stopped by a dealership and they reset some kind of a chip to "relearn" any engine changes and/or driving habit changes. No issues ever since. Stalls and a VERY rough idle prior too. I hope this helps.

    Tom
  3. BackwodsChevy

    BackwodsChevy New Member

    I considered this but I just knew it was something small.It,s crazy even though the battery was disconnected .I guess the next time I will just disconnect the ground!!!

Share This Page