Should i Trade my 2010 CC Z71 in re oil consumption

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by gsvar200467, Dec 4, 2012.

  1. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    I'm going to the dealership now.......Wish me luck....Details to follow....
     
  2. gsvar200467

    gsvar200467 New Member

    I will for sure. I've already spoke with gm customer support too. Only reason I'm even taking time to mess with it is so I have proof of what's going on. As mentioned I had to how them my oil covered spark plugs last time to get there attention. Ill update this afternoon
     
  3. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Ok my update.. Just got home They checked and I was down 1/4 Qt in 1100 miles I have to go back in 1000 more. He said it looks like I will be getting the Rebuild...I even took video of the Blue and heavy smoke this morning and showed him..

    2nd note Asked him about the new Code I am getting Bank #1 sensor #2 02 sensor He says nothing to do with the smoke.. And it is NOT covered.. Ok so How much to replace and how hard is it? Anyone know??

    Dealer says about $200.00 :grrrrrr:
     
  4. Pikey

    Pikey Moderator Staff Member 3 Years ROTM Winner 1000 Posts

    Easy to replace, if you get the o2 sensor part number you can get it on amazon for around $50
     
  5. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    will look for it as soon as I know which one it is..Remote start is not working again.. :grrrrrr: Telling you getting Sick of GM....
     
  6. Sierraowner5.3

    Sierraowner5.3 Rockstar 3 Years 1000 Posts

    sorry for all the issues enkei......

    Alex
     
  7. Pikey

    Pikey Moderator Staff Member 3 Years ROTM Winner 1000 Posts

    PM me your VIN if you can not get the number. I can call GM monday and get the number from them for you. Bank one sensor 2 should be on the driver side after the cat.
     
  8. ChevyBoy2009

    ChevyBoy2009 Rockstar 4 Years 500 Posts

    Taking my truck in tom for the oil consumption issue...used a quart to 1.5 quarts in 962 miles!...rough idle,no power,blah blah blah!...i dont have to do the text so they said bring it in and we will tear it aprt i guess??...if i still have this issue within the next year,im gonna trade in it and get a diesel!...enough said...btw truck only has 64k
     
  9. RSM2

    RSM2 New Member

    My 1999 GMC has about 200K on it and uses maybe 1/2 between changes. I was thinking about getting a newer truck...maybe I won't
     
  10. GuyGene

    GuyGene Member

    That's the ticket, RSM. I'm in same situation. These issues are keeping me from getting a new truck from ANY brand! F150 shakes, shudders - Ford says normal! Tundra shakes, cheap interior, more problems on their forums than any other! Ram - hmmm, actually, I'm seeing fewer complaints on Ram forums than any other! Surprises me! Differential pinion nut was problem on earlier Rams, but seems to be fixed now. If I can find a decent Ram dealer (man, their dealers are terrible!!), I'll test drive one. No brand loyalty with me.
     

Share This Page

Newest Gallery Photos