silverado 1500 cruise control problem

Discussion in 'GM Powertrain' started by mitchlbuck, Feb 28, 2010.

  1. mitchlbuck

    mitchlbuck New Member

    ok so...i went ice fishing the other day and was driving in about a foot of snow on the ice. i got back out on the high way and try to set my cruise and it didn't work. i pressed it repeated times and it would flash on quick than go off right away... can anyone tell me whats going on. could it be frozen if thats even possible?
  2. lsutoms

    lsutoms New Member 100 Posts

    were you sliding on the road? i dont live in snow but if it doesnt have a problem and still does this my guess would be its noticing your sliding and won't turn on..... just a guess buddy lol
  3. mitchlbuck

    mitchlbuck New Member

    no i wasnt slidin. most if the snow has melted on the roads where i am
  4. unplugged

    unplugged New Member 1000 Posts 100 Posts

    Check the brake light bulbs, and otherwise it could be a stuck/defective stoplight switch. I had a situation where everytime I turned on the right signal, the truck would drop out of cruise. If the right signal was on, the cruise would not engage. Not affected when the left signal was on. The right rear bulb had burned out. I replaced the bulb and the cruise control resumed normal operation.
  5. SupplySgt

    SupplySgt New Member 100 Posts

    I'd check the brake light switch by the brake pedal. if it's not that then it's probably the cruise control module. module went out on my 96 when I had it and I went junkyard prowling and got one dirt cheap (like $25 but that was 3 years ago). Check the brake light switch first and then test the cruise module itself.

Share This Page