Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Squeaky Engine

Discussion in 'GM Powertrain' started by W1T3OUT918, Oct 28, 2012.

  1. W1T3OUT918

    W1T3OUT918 Member

    Now,,, i have changed the main drive pulley arm and all,,idler pulley and the main drive for the a/c and i still get that cold belt sqeak sumtimes, i mean,, i jus couldnt figure out what it could be. Since its in the engine compartment it echoes and is misleading but ill bet my paycheck on it emitting from the Alternator pulley,,it sounds like it comes straight from that..its actually not as bad now since i put the 3 neew tensioners on,,but it does it for jus a lil bit before it warms up and then its good.. Before the new tensioners it was squealing like a pig everywhere i went! but now jus starts up a lil bit and stops,,anybody else had this problem,,, after spending over $200 or more on just parts and labor puttin on, i say if it aint broke dont fix it,,which is why i havent changed the Alternator yet.:idea:
     
  2. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Have you tried using a stethescope to locate the squeek?
    If you have someone else start the truck while your under the hood with a mechanics stethescope you might have a better chance locating it.
     
  3. W1T3OUT918

    W1T3OUT918 Member

    yeah my dads buddie is an awesomely greeat mechanic he used his stethescope but couldnt find anything thats why we ended up replacing like 3 parts,,still couldnt find it,,but it jus sounds like its emitting from that front pulley on the alternator..
     
  4. Marcus A.

    Marcus A. Rockstar

    Sometimes if the battery is not real good the alto belt will squeal after start up. The battery drains enough on start up to cause a bigger load on the alto making it hard to turn-making the squeal. My 6.0l has been sqeaking for some time. Going to replace all belt and tensioner
     
  5. W1T3OUT918

    W1T3OUT918 Member

    yeah i reckon its the pulley on the front of the alternator. its funny cuz it will start sometimes then stop and not squeak at all,,, and i have an OPTIMA red top battery so it shuldnt be pulling to hard
     
  6. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    If the squeal is only on a cold start and it goes away after a very few minutes, change the belt. That will fix the problem.
     
  7. Conlan Rose

    Conlan Rose Active Member 2 Years 1000 Posts

    As stated by [MENTION=54249]RayVoy[/MENTION] its the belt. I had the same problem and was blaming everything but the belt. Threw in a new belt and walah fixed and no squeak. I had literally the exact same symptoms, except I noticed how lose the belt was even with the new tensioner. Also Rayvoy pointed out just change the belt, he was 100% right...
     
  8. RayVoy

    RayVoy Well-Known Member 2 Years 1000 Posts

    Haha, thanks for the mention Conlan; it wasn't a guess, like both of you, I changed other things before I tried the belt. The old one looked fine, I even tried to wash it, it would still squeal on a cold start. I kept the old one for a spare.
     
  9. Conlan Rose

    Conlan Rose Active Member 2 Years 1000 Posts

    Yay learning from experience! :lol:. And yah keep the old belt it may be useful later and then you have an example of what belt to get.
     
  10. stchman

    stchman Active Member 1 Year 1000 Posts

    The old fan belts (non-serpentine) you could hit them with a little Armor All to stop squeaks. Try that with a serpentine and it can come off.
     

Share This Page