Squealing noise coming from the serpentine belt area

Discussion in 'GM Powertrain' started by willbradfan, Nov 4, 2011.

  1. willbradfan

    willbradfan Rockstar 100 Posts

    I just started getting a squealing noise on wednesday and I was trying to figure out if it was the belt today but I really couldn't figure out if it was the belt or not. I had it in park and varied the gas quite a bit to see if the noise would go away because I assumed it would go away at higher rpms but it didn't. I am starting to think that it might be a bearing on one of the pulleys? I can record the noise on my cellphone video camera probably if that would help diagnose it. The noise is driving me nuts since I can hear it on the highway sometimes as well. It goes away and comes back on the highway.

    Also, the belt tensioner and the idler pulley were replaced in 2009. Truck was just in the dealership and i called them yesterday and they said its probably oil on the belt from when they cleaned the engine, it was in the shop tuesday/wednesday. they said give it a few days and it'll go away, well it hasnt gone away...

    Any help would be greatly appreciated, thanks!
     
    Last edited: Nov 4, 2011
  2. willbradfan

    willbradfan Rockstar 100 Posts

    Alright, i found the cause of the problem. Dealership got a lot of oil on the belt system and had to degrease all of it and put a new belt on it to fix the squeal.
     
  3. Caddiac

    Caddiac Rockstar 3 Years 1000 Posts

    Thanks for the follow up. SOme one is going to really appreciate that information one day!
     

Share This Page

Newest Gallery Photos