1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Stereo Clock

Discussion in 'Audio, Video & Gadget Tech' started by coldashell?, Apr 9, 2010.

  1. coldashell?

    coldashell? New Member

    I have a 96 burb.. Factory tape and CD stereo.
    The problem is this....
    The system works fine no problems except, it will not hold time. I am setting it correctly, but as soon as the truck is turned off, then back on it gives some random time(5:26). Ive checked fuses and what not, just wondering if there is another avenue to pursue, or is it one of those quirks that happen.
  2. vncj96

    vncj96 New Member 1000 Posts

    It does happen, are you losing the radio station presets as well? Could have a loose wire, or its just time to replace it.
  3. murdog94

    murdog94 New Member 1000 Posts

    X2.. Gms stock radios werent the greatest...
  4. Dukeschevy

    Dukeschevy Member

    Damn AC delco! I would check the wires, your consatnt power may be loose or something
  5. coldashell?

    coldashell? New Member

    Thanks for the help.
    I don't loose presets, just time. I'm going to check the wiring today. i think it is going to be one one of those
    "deal with it or replace it"'. I was born and raised in GM vehicles and, every one of them has had a radio problem with the exception of one....1985 Cavalier:rofl:

Share This Page