Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Superchip 2815 help please!!

Discussion in 'Chevy Silverado Forum (GMC Sierra)' started by Tylert003, Mar 15, 2014.

  1. Tylert003

    Tylert003 New Member

    So, first off I got a 2005 z71 last night. First z71 I've had. And I love it. It's awesome. Okay now. My question is, how in the world do I get my programmer to work? I plugged it in and it doesn't come on. Tried with truck off, truck on, truck cranked. Idk what it's problem is, it won't come on. It was set up for gas mileage, but like most people. I wanna play with it and see what it'll do. So is there a truck to getting it to come on? I heard something about a fuse being blown and the way I could tell is a cigarette lighter plug wouldn't work, and the passenger side one doesn't. Anyone got any help for me? Also, here's a pic of my truck for those who wanna see it.

    [​IMG]
     
  2. JimmyA

    JimmyA Member 1 Year 100 Posts

    Nice Truck! Welcome aboard! You should try contacting, Superchips tech help. Good luck.
     
  3. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Is it a new programer? Something you had for a past truck?
     
  4. Tylert003

    Tylert003 New Member

    No. Came with the truck.
     
  5. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    could be a fuse Do to a Autoparts store and let them try to read your truck.. See what happens..
     
  6. j cat

    j cat Rockstar 4 Years 1000 Posts

    check all the fuses .. not exactly sure which one feeds the dash power sockets. could be cig fuse.

    if these sockets have no power then the dtc obdII connector will be dead no power..
     
  7. Tylert003

    Tylert003 New Member

    Alright. Appreciate the help guys
     
  8. Tylert003

    Tylert003 New Member

    It was a fuse. Got it fixed. Thanks for the help everyone
     

Share This Page