sway bar bushings, car feels all over the place

Discussion in 'Lifted & Offroad Suspension' started by 07cobaltss/sc, Dec 28, 2009.

  1. 07cobaltss/sc

    07cobaltss/sc New Member

    01 silverado 1500 2wd the car just feels like it moves around more on the road like a boat. just put 20" ss rims on it and didnt get the alignment or balanced or anything yet. but it seems like it might be the sway bar bushings have gone bad.
    what do you guys think and wheres the best place to get poly ones?
     
  2. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    How do you mean "all over the place"
    New taller unbalanced tires and wheels could cause this feeling.
    Unless you have alignment issues you dont need to get it aligned because you put on new tires.
    How many miles? What condition is the steering gear in? Are the tie rod ends and ball loints in good shape?
     
  3. 07cobaltss/sc

    07cobaltss/sc New Member

    had the alignment done the toe was off.
    but it just feels like it wants to go to the sides. still waiting to see if its still there on the highwa. but the tie rods and all that look fine, along with the endlinks.
     
  4. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    What pressure are you running the tires at?
    This makes a lot of handling difference in big wide tires.
     
  5. 07cobaltss/sc

    07cobaltss/sc New Member

    i think between 32-34psi its on 275s all around
     

Share This Page

Newest Gallery Photos