The A/C only came on in the OFF position... fixed!

Discussion in 'Audio, Video & Gadget Tech' started by Springthing, Sep 11, 2008.

  1. Springthing

    Springthing Epic Member 5+ Years 1000 Posts

    Ok, so, to recap, I had a problem with my A/C. New (to me) '99 Suburban with a few slight issues.

    The A/C would only work in the off position. It would blow on high and then turn off in any of the other settings. (actually, sometimes worked in the 1 position)

    I came on here and posted the problem, and it was suggested that I would need a new controller. So I looked around and found out that the console/controller that was on the truck was actually not the original. I was missing the button to turn on the rear defrost lines!

    So I ordered the new control unit WITH the rear defrost button and installed it the minute it got here.

    IT WORKED!

    The A/C actually comes on when it's supposed to and turns off when I turn the switch off! Woot!

    $100 fix, 5 - 10 minutes to pull off the dash trim, pop out the old controller, unplug, replug on the new one, put stuff back together and tah dah!

    Thought I'd post in case anyone else ever sees this problem.

    Thanks for the fix advice! :great:
     
  2. vncj96

    vncj96 Epic Member 5+ Years 1000 Posts

    :party:Glad to be of some help!!
     
  3. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    What are you referring to?
     
  4. Springthing

    Springthing Epic Member 5+ Years 1000 Posts

    Spam post?
     

Share This Page

Newest Gallery Photos