Top end knocking?

Discussion in 'Chevy C/K Truck Forum' started by okysmokey911, Oct 26, 2010.

  1. okysmokey911

    okysmokey911 Rockstar 100 Posts

    I have had a really hard time getting the timing right on my truck so I have been playing with retarding and advancing. My truck has been running way too rich, but from messing with the timing I believe I caused another issue. Lately I have noticed, only on the highway, a top end knocking or pinging sound coming from my engine. It sounded like I had loose rocker arms, but I tightened all of them to specs so I have no idea what the issue is. Could my timing still be off?
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Oh your timing is WAY off that is detonation, you will want to get that set properly ASAP, to 0 degrees TDC with (i dont remebre which) a wire disconnected. If you dont have the ability i paid my local shop $40 to get it straight for me.
     
  3. okysmokey911

    okysmokey911 Rockstar 100 Posts

    I may have to take it to a shop because I have tried several times to set it to tdc with a timing light....
     
  4. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Have you disconnected the wire that i mentioned? there are a few threads that talk about that wire.
     
  5. okysmokey911

    okysmokey911 Rockstar 100 Posts

    Yes I disconnected the wire them set at top dead center and then plugged the wire back in. I noticed that after I do all of this and then start the truck back up that the timing mark is no longer at top dead center. I know that the computer takes control of advancing and retarding but the timing mark disappears completely... So what's that about?
     
  6. phoebeisis

    phoebeisis Epic Member 5+ Years 1000 Posts

    Are you saying that after you reconnect the wire the timing mark-as lit up by the timing light - is so far gone you can't see it?

    What "mark" is your light shining on when it "is triggered"? At idle it should be advanced maybe 10-15 degrees and full advance (at 3000-4000 rpms or so)is probably 32 degrees or so.

    Is your timing so far advanced that you are beyond all the marks? It has been years since I had a vehicle that actually needed to be timing, but usually there is at least 40 degrees worth of marks in the advanced ranged and 10 degrees or so in the retarded range.

    What mark is it shining on at idle-10-15 degrees or so advanced?
     
  7. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    No he cant get it to time to 0degrees TDC to begin with so there is no baseline.
     
  8. okysmokey911

    okysmokey911 Rockstar 100 Posts

    Yeah the problem is I cant get it as baseline tdc.... I hook up the timing light start the truck, disconnect the wire, turn the distributor till I am at 0 tdc, plug back in the wire and then shut off the truck. Once I start the truck back up, you can no longer see the timing mark ( with the timing light )... its like its advancing or retarding it ridiculously far.
     
  9. langss

    langss New Member

    It sounds like the ring on the Harmonic Balancer has slipped.So your Timming Mark has moved.Bring the motor up to TDC on the No.1 cylinder and look for the 0 timming mark on the balancer. It should be very close.If not the ring has slipped.Time for a new balancer.
     
  10. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Another cause cold be in that MSD ign. if it is a trick style that you can adjust etc, and or else the pick up coil cold be shot as well. Causing the timing to be to far off, that is if the harmonic balancer ring isnt slipped as mentioned.
     

Share This Page

Newest Gallery Photos