TPMS light

Discussion in 'Audio, Video & Gadget Tech' started by 07 redrado, Feb 14, 2008.

  1. 07 redrado

    07 redrado Rockstar

    hey yall i installed a aftermarket DVD player in my NBS silverado and 2 days later mt TPMS light came on and the display center says "service pressue monitor system" i have had it at two different dealers and neither can give me an exact answer of what is wrong. all they can tell me is that the sensors are not communicating. they wanted me to leave it with them for the day but they dont give rental cars so i couldnt sit there all day. but just wondering if anybody else has had this problem. oh and i have the correct harness that cost $200 and dealer #2 didnt know if i put the stock radio back in if it would fix the problem.:grrrrrr:
     
  2. 07 redrado

    07 redrado Rockstar

    just to reply to my own post, i finally got my TPMS light fix. it was the receiver that the tire sensors send the signal to. it had gone bad. got to love all this electrical crap.
     
  3. drumrob

    drumrob Rockstar 100 Posts

    Thats wierd cuz I have a 07 Silverado new body also and my pressure sensors went on. I just took it to the dealership and I think they just reseted the sensors. Every other week I do get something on dash saying checking pressure and it honks twice, Im not sure if thats normal
     
  4. 07 redrado

    07 redrado Rockstar

    i know that when it honks twice that u are putting it in learn mode, basically ur telling the computer to relearn where the wheels are on the truck. but to have it on that often isnt mormal. one of ur wheel sensors could be going bad or ur receiver box isnt getting a signal, going out, there are many different reasons. i wish i could take mine out, but then the light would be on all the time.
     
  5. finalday7

    finalday7 Epic Member 5+ Years ROTM Winner 1000 Posts

    Yeah ever since the day I bought my truck at least once a week one of the sensors would say low tire pressure. There was no leak they never put air in the tire the sensor was jus bad. I changed to aftermarket wheels, tires and opted not to have the sensors put in. So I have the light on the dash but it doesn't bother me. I'm just waiting on someone to figure out how to turn it off :great:
     

Share This Page

Newest Gallery Photos