1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

TPMS service / sensor fail

Discussion in 'General Chevy & GM Tech Questions' started by deepstuff, Nov 16, 2010.

  1. deepstuff

    deepstuff New Member

    Since the weather has gotten cold the TPMS of my ’07 Silverado intermittently looses a reading from one of the tire sensors. Is this sensor failing? Is there anything that can be done to repair the sensor or is it only replaceable? Are they all going to fail around the same time? Should I now replace all four?

    Thanks!
  2. sstoner911

    sstoner911 New Member 1000 Posts

    I had this same problem....not so much from the cold here in tucson however! Out started worth one sensor then progressed to where none of the m were transmitting.
    Dealer tried to relearn them as the manual way wasnt working.

    Long story short I replaced them one by one until they all worked..i ended up replacing 2 then the other 2 started working.....wired huh!
  3. stephan

    stephan New Member 1000 Posts

    Is it always the same sensor that is loseing the reading or is it ramdomly all 4 at different times? If it's always the same one then repl that "one" sensor.

Share This Page