1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Tranny Help Please - 05 Tahoe--

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by remist17, Jan 27, 2010.

  1. remist17

    remist17 Member

    OK so I bought this Tahoe with 45K on it about one month ago Aprox 2500 miles since I bought it. Today leaving work the truck seemed to miss or slip a little. So when I got home I checked the Tranny fluid. The stick was dry! I checked under the truck from the front to back. Everything is clean. Looks brand new. No leaks . I started adding fluid to the tranny and running it through the gears. I then would shout it off and let it sit for 1/2 hour. I started it up and warmed it up and checked it, long story short I added 1 1/4 qrts of fluid and its just at the bottom of the hot check marks. I drove it in again to work and checked it right after driving and its still at the bottom of the check mark.

    Any help ? Suggestions?


    *** Was Told to ask a specific question ..... Weres the fluid going? There is no wet spots nor signs of leaks.
    Last edited: Jan 28, 2010

Share This Page