Tranny Issues

Discussion in 'GM Powertrain' started by TreeMan, Mar 21, 2010.

  1. TreeMan

    TreeMan New Member

    I have a 91 2500 chevy 6 lug w/ a 5.7 tbi 4x4.I believe I have a 700 tranny in it. It seems to rev high shifting from 1st to 2nd which then it goes into 2nd hard. I'm I looking at a reman or a simpler fix? No engine codes. Tranny fluid is a dark crimson color.
     
  2. SupplySgt

    SupplySgt Rockstar 4 Years 500 Posts

    Tranny fluid should be bright red. with it being a 91 it's a 700R4 tranny so you're not gonna get any codes from it since it's not hooked up to a computer. One thing to check is the Throttle Valve (TV) cable that connects the tranny to the throttle body. A TV cable that's not adjusted properly will cause weird shifting and will burn up a tranny pretty quick.
     
  3. ippielb

    ippielb Epic Member 5+ Years ROTM Winner 1000 Posts

    Try changing your transmission fluid, and putting a new filter in it. You'd be surprised how much that does for you.
     
  4. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    Like the Sgt said it could very well be the cable. Sometimes they loose the adjustment or become frayed. The TV valve inside the valve body can get stuck as well. Look closely at the adjustment and see if it looks like someone has messed with it or the cable is frayed. If it looks OK try making the cable longer by popping the latch and sliding the cable forward about 1/4" forward from where it was originally. Mark the cable before you start so you know where it was originally.
     
  5. Silverado Junkie

    Silverado Junkie Rockstar 4 Years 500 Posts

    While we're talkn about it, what tranny is in my '95? Its a 1995 1500, with the 5.7l in it. Is it the 4l60e?
     
  6. Jimmiee

    Jimmiee Epic Member 5+ Years 1000 Posts

    Yes your 95 will have 4L60E.
     
  7. Silverado Junkie

    Silverado Junkie Rockstar 4 Years 500 Posts

Share This Page

Newest Gallery Photos