Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

Tranny question

Discussion in 'GM Powertrain' started by sierra11, Sep 5, 2012.

  1. sierra11

    sierra11 Rockstar 100 Posts

    Hey guys some of you might notice I posted something similar a few weeks back. This past weekend I drove to Mobile from Tuscaloosa for Labor day well on the way down I had no problems with my transmission and also while I was there I pulled our boat to the river also with no problems. When I was on my way back to Tuscaloosa though I stopped about halfway to get some food. After getting back on the road I started noticing what felt like the transmission slipping each time I started going. I pulled off in a gas station to check the fluid, which was at good level. I did notice the tranny temp was at about 200 so I sat for awhile to let it cool down. I didn't have any problem after that. So my question is do I have a problem because I have taken it to two places and they say there is no code being shown?
     
  2. moogvo

    moogvo Epic Member 5+ Years 1000 Posts

    At this point, I wouldn't go thumbing through the yellow pages looking for someone to rebuild it. Drive it and see if the symptoms return. If you don't have an auxiliary transmission cooler, add one!
     
  3. ahmitchell1

    ahmitchell1 Rockstar 4 Years ROTM Winner 1000 Posts

    X2 what moogvo said. I wouldn't worry about it until you feel it again. A lot of times it can be the computer crapping out. Of you end up taking it to a shop in Tuscaloosa look at the one down 10th by the old archebalds. Or there's one down frank thomas towards skyland
     
  4. sierra11

    sierra11 Rockstar 100 Posts

    Yeah I know I should probably add a cooler, I'll wait and see if it does it again cause I have to drive to Mobile again at the end of the month
     
  5. Big_Mike

    Big_Mike Member 100 Posts

    I'm not sure what what year and type of vehicle you have but something to consider is this... Does it have a "tow/haul" button? If so, were you using it? I've heard that transmissions can overheat if the "tow/haul" button is not being used when the vehicle is towing/hauling.
     
  6. sierra11

    sierra11 Rockstar 100 Posts

    It's an '04 Sierra 2500 and I use it when I tow of course but this was when I was heading back up to school.
     
  7. aloxdaddy99

    aloxdaddy99 Rockstar 3 Years 1000 Posts

    My old work truck had a similar issue. I took it back to the dealer to have it looked at since it was still under warranty. They looked at it and reflashed the "computer" as they told me and the problem was corrected. I talked to my brother in law who works at an Aamoco trans shop to see if that was normal. He said he had heard of it in the passed so I felt a little better. Since it was a company truck I wasn't aloud to mess with the truck at all so I am not sure which tranny it had. Just an FYI. Good luck.
     
  8. sierra11

    sierra11 Rockstar 100 Posts

    Reflashed the computer? Did they say why or what was wrong. Mine definitely isn't under a warranty only my wallet
     
  9. Als09Sierra

    Als09Sierra Rockstar 4 Years ROTM Winner 1000 Posts

    My 6spd does something similar although there's no rhyme or reason to it. Had it in to the dealer a few times and each time they couldn't replicate it. They thought they fixed it saying that the computer program was wrong and thought I may have had it programmed, which I hadn't. Still get a slip once in awhile and hard shifts every once in awhile. Not sure if you have the same tranny, or if it's the same issue but good luck and keep us posted.
     
  10. aloxdaddy99

    aloxdaddy99 Rockstar 3 Years 1000 Posts

    They didn't say what was wrong. You know how the stealership is be vague and if that doesn't work be very vague!!
     

Share This Page