Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Transmission problem

Discussion in 'Chevy C/K Truck Forum' started by jsmith4816, Jan 20, 2013.

  1. jsmith4816

    jsmith4816 Member 2 Years 100 Posts

    Hey guys and gals, having a problem with my transmission. Was driving to the store and stopped at a light. When i went to take off, my truck didn't want to go. Felt like it never downshifted from OD as i approached the light and stayed in that gear. The take off was real slow. Checked the fluid and that was good. Was reading a few posts on here stating that the fluid will smell like sh** if it was bad, and no odd smell.

    Drove it today and it started fine. I turned around and headed back home, and it started doing it again. Seems like it gets stuck in drive, and never shifts to over drive. I will run at 55mph, and my rmps will be at 2500. I had this problem a few years ago, and a tranny flush and filter change did the trick. Maybe the same problem? It is the original transmission and has never had work done to it, outside the fluid change. Maybe a solenoid?

    The transmission would usually shift hard going into second. Not real hard, but not smooth like the others shifts. When cold it would also take a while to shift to OD. So maybe a rebuild or new tranny is needed?

    Also, probably a stupid question but is it safe to drive when if it does not shift to OD? The manual says to just use drive when towing heavy loads so I would imagine it would be?
  2. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Ok quick ? Do you have a remote start in that truck? What year is it?
  3. jsmith4816

    jsmith4816 Member 2 Years 100 Posts

    No remote starter. Its a 94k1500 with 167,9xx miles.
  4. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    Do you have 1st or 2nd?
  5. jsmith4816

    jsmith4816 Member 2 Years 100 Posts

    Nope, just stays in that one gear and reverse.
  6. Enkeiavalanche

    Enkeiavalanche Rockstar 4 Years ROTM Winner 5000 Posts

    I'm not a Trans pro.. I do know when the trans went on my 02 Avalanche It was a Ing Mod that went and locked up the truck in 3rd and 4th.
  7. jsmith4816

    jsmith4816 Member 2 Years 100 Posts

    Drove her to Advanced Auto to see if they could run it on their computer. Shifted fine, even had to use 4wd to get out of my apt complex. They couldnt because its a 94, and their tool can only do a 95 and newer. Rats, just my luck lol. They did recommend me to a shop, so went there and they were too busy to scan it at the moment, so I am going back tomorrow after work. With it shifting fine, I'm just going to have them them do a flush, filter change, and solenoid.

    Is it safe to drive with it being a hit and miss? I drove my camaro to work last night and boy did the drive home suck. Tonight is expected to be worse, so I would much rather drive my truck then car.

Share This Page