1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Transmission Problem...

Discussion in 'General Chevy & GM Tech Questions' started by SwamperRider, Sep 21, 2009.

  1. SwamperRider

    SwamperRider New Member

    Ok, I'm new to the forum and my name is Kenneth Harrington, I'm from this small town named Crowley that's located in Louisiana.

    Well ok people I have a 1999 Chevy Silverado z71 that just got the transmission rebuilt and put back together, and now the trans won't shift out of 1st gear. People said I may have to blow out the lines? How do I do that? And how hard is that to do? And could that be the problem? I'm just curious because I can't really drive it daily like this and I would like to get it fixed.

    So if you know the problem and if yall can please tell me how to blow the lines out and how hard that would be to do. I'd appreciate it.

    Thanks,
    Kenneth
  2. Mean_Green_95

    Mean_Green_95 New Member 1000 Posts 100 Posts

    My brother does a big fireworks show in Crowley every 4th of July and every Christmas. I'm from Pearl River, LA, but right now I'm in Baton Rouge. As far as the trans, the shop should have cleaned them out.
  3. SwamperRider

    SwamperRider New Member

    They said they forgot to clean the lines out. I just told them I was gonna do it myself. I'm just wondering how hard is it to do & how to do it?

    And yeah I watch the fireworks shows, they are pretty awesome!
  4. Jimmiee

    Jimmiee New Member 1000 Posts 100 Posts

    Don't waste your time blowing out the lines. This is NOT your problem. You probably have a speed sensor or MLP problem. How about a little more info in this. Who rebuilt it? Who installed it?
  5. unplugged

    unplugged New Member 1000 Posts 100 Posts

    Welcome SwamperRider! Sorry to hear that you've got tranny troubles. If anyone can help out, jimmiee is the man. I hope we can help you get your ride back on the road.
    Last edited: Sep 22, 2009
  6. SwamperRider

    SwamperRider New Member

    Hey thanks Unplugged. And Jimmiee I'm trading my 1999 z71 for another one and that is the one with the tranny problems. I'm thinkin bout doing to because it has a 10" suspension lift with 39.5 Iroks and 5:13 gears front and back. I'm not sure who rebuilt the trans and who installed it, but the guy said he was wrong and that the truck shifts from 1st to 2nd then it won't shift into high gears. He told me the lines wear dirty or w/e and they forgot to blow them out or w/e. So i'm not sure what's the problem with it. If anyone knows what could be the problem feel free to help :)

    And as far as the speed sensor and the MLP problem...how hard is it to change? And how much are those to change?

Share This Page