1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

Transmission problems

Discussion in 'GM Powertrain' started by ZSI52, Apr 13, 2009.

  1. ZSI52

    ZSI52 New Member 100 Posts

    I bought my truck from a GM dealer in October. It has run flawless everyday until about 2 weeks ago. The transmission started acting up. Some examples. Like today I started it and I let it run for a few minutes and then put it in reverse and I barely had my foot on the gas and it started to like Whind up for a few seconds and then the truck kind of jerked and then it started driving fine. Lately when I take off it will shift from 1st to 2nd extremely hard and then after that it shifts smooth. So does anyone have any ideas? Its a 2006 Chevy Silverado 1500 2wd automatic with tow mode. Im taking it to my friends transmission shop tomorrow and hes going to see if theres anything wrong with it and put some new fluid in it.
  2. Jimmiee

    Jimmiee New Member 1000 Posts 100 Posts

    Zack,

    Your transmission is either low on oil or the filter is starting to clog up with debris. Did you check the oil with the engine running? If the oil level is OK then you need to get it into the shop pronto.
  3. ZSI52

    ZSI52 New Member 100 Posts

    Thanks for the reply. I checked all the fluids several times. I checked the fluid while it was running . They all look good. I'm at my friends transmission shop right now. So I guess we will hopefully find out what's wrong with it.
  4. ZSI52

    ZSI52 New Member 100 Posts

    Just got back. Seems to be working great now. Thanks for the reply.

Share This Page